Android43以下的设备不支持BLE,是硬件上不支持,还是协议上不支持?_Android_编程问答

Android43以下的设备不支持BLE,是硬件上不支持,还是协议上不支持?

来源:互联网  时间:2018/1/28 2:03:29

关于网友提出的“ Android43以下的设备不支持BLE,是硬件上不支持,还是协议上不支持?”问题疑问,本网通过在网上对“ Android43以下的设备不支持BLE,是硬件上不支持,还是协议上不支持?”有关的相关答案进行了整理,供用户进行参考,详细问题解答如下:

问题: Android43以下的设备不支持BLE,是硬件上不支持,还是协议上不支持?
描述:

最近公司要开发一个蓝牙解锁的app
用蓝牙的方式来解锁
如果我需要最低兼容到 android 4.2 应该怎么做呢?


解决方案1:

android os 不支持
就是低级别的系统中没有BLE相关的方法给你调用

从理论上来说 除非你自己修改android的系统,自己实现rom,将ble相关的代码移植到4.2系统内,然后对java层提供sdk调用你封装的ble api,这样的技术大概类似于mipush,而且更加复杂,因为涉及android操作硬件,系统烧录
否则无法实现你说的功能,如果你是想研究android系统的烧录和相关代码植入,系统剪裁定制,还可以考虑

如果只是为了app开发,建议你不要考虑BLE兼容4.2的问题,在app层面不可能实现

解决方案2:

兼容的写法就是,蓝牙4.0,蓝牙2.0都写进去,支持BLE则使用BLE。

使用此API检查支持与否
context.getPackageManager().hasSystemFeature(PackageManager.FEATURE_BLUETOOTH_LE)

上一篇Android Studio Module嵌套依赖aar问题
下一篇想要在一个布局里嵌入令一个布局要怎么写
明星图片
相关文章
《 Android43以下的设备不支持BLE,是硬件上不支持,还是协议上不支持?》由码蚁之家搜集整理于网络,
联系邮箱:mxgf168#qq.com(#改为@)